Tutoriel : Comment intégrer le caractere  n du Soninké dans
votre clavier francgais?

Auteur : Fodyé Cissé — Systéeme d’exploitation : Microsoft XP, Vista

La langue Soninké utilise abondamment le caractére np dans son écriture. Malheureusement, le clavier
francais ne comporte pas en standard ce caractére spécial et son code ASCII ne permet pas non plus de
l'insérer directement dans un texte grace a la combinaison [Alt] + <code ascii> .

Certaines personnes, pour utiliser ce caractéere spécial, sont obligées d’ouvrir Microsoft Word , d’'aller dans
les caracteres spéciaux, puis de le copier depuis cet endroit afin de I'insérer ailleurs.

L'objectif de ce tutoriel est donc d’associer un raccourci direct avec le clavier a ce caractere spécial gu'est le
n permettant ainsi de gagner un temps fou lors de I'écriture de ce caractére en langue Soninké ou dans
d’autres langues nationales africaines I'utilisant.

Nous allons dans un premier temps utiliser le logiciel Microsoft Keyboard Layout Creator  qui permet de
créer et de personnaliser un clavier virtuel. Ensuite, grace a la table des caractéres de Microsoft , nous
identifierons ce caractére nj et I'insérerons dans notre clavier virtuel. Le clavier sera ensuite compilé avant
d’étre intégré dans les options régionales de Microsoft comme clavier par défaut du systéme.

Quelques exemples de l'utilisation de ce caractére n en langue Soninké

Ce caractére n est beaucoup utilisé dans I'écriture Soninké. Il se prononce comme dans le son nasal final de
parking ou de dressing .

Naame = Inondation
Kanne = Or

Tonnu = Vérité
Fanne = Fleuve

Nous associerons le caractéere n aux touches [AltGr] + [n] comme raccourci.

http://www.softpedia.com/progDownload/Microsoft-Keyboard-Layout-Creator-
Télécharger le Download-12303.html

logiciel Microsoft
Keyboard Layout
Creator gréce au
lien en face. Une fois
dans la page, cliquer
sur le lien : External
Mirror 1

Installer le logiciel en fi. U 1

double-cliquant sur . : —Eesi ' E
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Cliquer sur Next
dans I'écran suivant
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Welcome to the Microsoft Keyboard Layout
Creator 1.4 Setup Wizard

The ingtaller will quide vou through the steps required toinstall Microzoft Kepboard Lapout Creator
1.4 on your computer.

WARMIMG: This computer program iz protected by copenght lavw and international treaties.
Unauthonized duplication or diztribution of this pragran, or ang portion of it may resulk in severe civil
or criminal penalties, and will be prosecuted to the maximum extent pozsible under the law,

Cancel Back | q Mewt > IJ‘

Sélectionner |
Agree, puis cliquer
sur Next

i Microsoft Keyboard Layout Creator 1.4

License Agreement

Fleaze take a moment to read the license agreement now, |F you accept the termiz below, click |
Aaree’’, then "Mext'’. Othenvize click "Cancel”,

MICROSOFT SOFTWARE LICENSE =
TERMS

MICROSOFT KEYBOARD LAYOUT CREATOR,
Version 1.4

NOTICE: INSTALLATION AND USE OF THIS SOFTWARE REQUIRES o
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Cliquer sur Next

Cliquer sur Next

i® Microsoft Keyboard Layout Creator 1.4

Select Installation Folder

The ingtaller will inztall Microzoft Keyboard Layaut Creatar 1.4 to the following folder.

Taoinstall in thiz folder, click "Mext'. Tao inztall to a different folder. enter it below ar click "Browse"',

Folder:
C:AProgram FilezhMicrozaft Keyboard Layout Creator 1,44 Browse. ..

Dizk Cost,..

Cancel < Back

i Microsoft Keyboard Layout Creator 1.4

Confirm Installation

Thie inztaller 1z ready to install Microzoft Kevboard Lavout Creator 1.4 on pour computer.

Click "Mest" to ztart the installation,

Cancel < Back




Laisser l'installation

i® Microsoft Keyboard Layout Creator 1.4

se terminer
Installing Microsoft Keyboard Layout
Creator 1.4
Mizrozaft Keyboard Layout Creator 1.4 iz being inztalled.
Pleaze wai...
Une fois que

I'installation est
terminée, cliquer sur
le bouton Close

osoft Keyboard Layout Creator 1.4

Installation Complete

bicrozaft Keyboard Lapout Creator 1.4 has been succeszstully installed,

Click "Cloze" to exit,

Fleaze uze Windows Update to check for any critical updates to the \MET Framework,

[Eamce! Back Cloze




Pour lancer le
logiciel, aller dans
Démarrer >
Programmes >
Microsoft Keyboard
Layout Creator 1.4
Une fenétre
identique a celle-ci
s'ouvre

= Keyboard Layout Creator 1.4 - ‘Layout01 Description’

File Edit %iew Project Help

Shawe the
O Caps Lock

Shift skates:

[] shift
ale+Ctrl
O alear

[ el

Contral

Legend

Assignable E]

(L] Current working directary

B[]  Built keyboard layout location |

| Alk Cankral

Decimal Separator (numeric kevpad) . |

L]

IReady

Dans cette fenétre,
aller dans le menu
File > Load
Existing
Keyboard...

Edit  Wiew Project

Mew
Load Source File, ..
Load Exi ]

Save Source File

Save Source File As. ..
Save As Image

Print. ..

Exit

Help

Chrl4+M
Chrl4D

Chrl+5

Chrl4+-P




Sélectionner
Francais , puis
cliguer sur OK

Load Existing Keyboard

You can choose one of the existing keyboard layouts on this
machine and its layout will be loaded {erasing all previously
entered information).

Bulgare

Bulgare {lakin)

Zanadien multilingue standard
Croate

Danais

Devvanagari - INSCRIPT

Divehi Machine 3 écrire

Divehi phonétique

Ezpagnal

Espagnal (warianke)

Estonien

Etats-Unis - Dvorak pour droitier
Etats-Unis - Dvvorak pour gaucher
Etats-Unis Drvorak,

Etaks-Unis Inkernational

Farsi

Féraien

Finnois
Finnoi

rangais (Eelgique
Frangais (Canada)
Francais (Suisse)
Frangais traditionnel {Canada)
Gaélique

GEargien

Grec

Grec (2200

Grec (2207 latin

Grec (319)

Grec (3197 latin

Grec latin

(>

b

| oK

Cancel ][ Help ]

Il charge le clavier
Frangais avec la
disposition de tous
ses caracteres.
Notez dans le cadre
en rouge les touches
de contréle dont
AltGr qui nous
intéresse
particulierement

~ Keyboard Layout Creator 1.4 - ‘Francais - Custom’

Show the
O Caps Lock

Shift states:

[] shift

Alk+CEr
C aler

[]ctrl

Contral

Legend

Assignable E]

Decimal Separatar {numeric keypad) . |

Deadkey .|  Current working direckaory |
c 4




Cocher la case
correspondant a
AltGr . Cela affiche
automatiquement les
raccourcis déja
associés dans le
clavier que nous
venons de charger.
On peut voir que
pour [ARGr]+[n] , il
n'ya encore rien
d’'associé.

2 Keyboard Layout Creator 1.4 - ‘Francais - Custom’
File Edit WYiew Project Help

Show the
O Caps Lock

Shift states:

[ shift
AlE+CEr
(alkr)

e

Decimal Separator {numeric keypad) |

Legend

Assignable [E

[key (.. Current working directary | \Decuments and SettingsFodys

| )

B[] Built kevboard lavout location | |

IReady Cbrl | Al

Dans Démarrer >
Exécuter... , taper
charmap puis
cliguer sur OK

Exécuter X l
= Entrez le nom d'un programme, dossier, document ou d'une
ﬁ ressource Internet, et Windows l'ouvrira pour wous,

Ourri @ | v

{ Ik i annuler ] [ Parcourir, .. J

Cela ouvre la Table
des caractéeres de
Windows , nous
permettant d’aller
copier le caractere n
gui nous intéresse.
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Choisir la police
gu’on veut (ici :
Verdana), puis, en

¥ Table des caractéres

iste des caractéres, | | Pelee: [0 Ve I e
identifier le ny . _ _ _ _ : _ _
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Sélectionner le
caractére n, puis

¥ Table des caractéres

Sélectionner puis Police | 0 Verdans v

Copier.
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Ensuite, retourner
dans le logiciel de
Microsoft Keyboard
Layout Creator 1.4
avec [AltGr] coché,
puis cliquer sur la
touche
correspondant au n .
Dans la fenétre
VK_N AltGr, cliquer
dans le champ de
texte, puis grace aux
touches [Ctrl]+[v] ,
coller le n dedans.

n [ Ok ][Cancel ][ All... ]

Le caractére n
apparait
automatiquement
comme associé aux
touches [AltGr]+[n]

= Keyboard Layout Creator 1.4 - ‘Frangais - Custom’

File Edit Wiew Project Help
Show the
aps Locl
DI Caps Lack
Shift states:
[ shift ’— -
| E e Return
M canar)
R <Hift
Decimal Separator {numeric keypad) |
Legend
Assignable[Z]
[Z] Current working directary |'..'-’.--.--:-.':---=r:l'..'-:‘--’.:---'-’":i",.l-s".F-‘--">'-Z-".=“1'E:'- docunments |[Z]
oad(.])  Built keyboard lavaut location | [l
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Dans le menu
Project > Test
Keyboard
Layout..., on peut
tester le résultat

Shiow the
[ Caps Lock

Shift states:

[] Shift
Al
(kG

[ Cer Shift




En appuyant sur la
touche du clavier
[AtGr] (enla
maintenant
enfoncée), puis en
appuyant en méme
temps sur la touche
[n], le caractére n
apparait dans la
fenétre de test. On
peut cliquer sur OK
pour fermer.

Keyboard Layout Testing

Type as you nomally would and your keyboard definition will be used to interpret the keystrokes. When you are done
testing, click the OK. button or hit ‘Escape’ to close the dialog.
n

[] Bidiectiondl [Right to Left]

Dans le menu
Project >
Properties... , on
peut donner un nom
au clavier qui vient
d’étre modifié.

=¥ Keyboard Layout Creator 1.4 - "Francais -
File Edit Wiew Bl

| Validate Lawvout
A gg';":fgfk Telst Kevboard Lavout. ..
Build DLL and Setup Package
Shift states: R
[] shift
Alt+CErl
(altGr)

Donner un nom et
une description, puis
cliguer sur OK

Properties

Drescription IFran;ais-SnninEg I |

Campany |C|:|m|:|any |

Copyright |{|:} 2007 Carmpary |

Language | French {France) W’ |

Optional settings:

[] CapsLack turned off when Shift is depressed (also known as ShiftLock)
[ JL. Shift+Back = left ta right marker (LRI}, R, Shift+Back = right b left marker (RLM)

[ Ok, ] [ Cancel ] [ Help




Compiler le projet
obtenur grace au
menu Project >
Build DLL and
Setup Package

2 Keyboard Layout Creator 1.4 - "Francais -

Fil= Edit

Showw the
[l Zaps Lock,

Shift states:

[] shift

alt4Crrl
(kGr

LI Project

Yalidake Lawouk

Test Kevboard Lavout, .,
Evi

Propetties. ..

Lorsque la
compilation se passe
bien, le message
suivant est affiché.
Cliquer sur OK

Keyboard Layout Creator 1.4

\y The Windows Installer package was built successfully at 'C:\Documents and SettingsiFodyéiMes documentsisoninks!'.

Swould vou like to open this directory?

I[ Qui ]I[ Mon

Cela ouvre le
dossier ou se
trouvent tous les
fichiers créés, dont
le setup.exe .
Double-cliquer sur
ce setup.exe pour
installer le clavier
généré dans
Windows

Lorsque l'installation
du clavier est
terminée, une
fenétre comme celle-
ci s'ouvre. Cliquer
sur Close pour
fermer.

amde4

iagt

 setup.exe
Kevboard Lavout Creator Boo,,
Micrasaft Corporation

soninke_i386. msi
Package Windows Installer
112 Ko

i Frangais - Soninkeé

Installation Complete

Francaiz - Soninkeé has been succezsfully inztalled.

Click "Cloze'" to exit.

i3E0

wiowed

soninke_amd&4. msi

M Package wWindows Installsr

112 Ko

soninke_iag4. msi

M Package wWindows Installsr

112 Ko




Lancer le Panneau
de Configuration
comme suit :
Démarrer >
Parametres >
Panneau de
Configuration . Puis,
double-cliquer sur
Options régionales,
date, heure et
langue .

Choisissez une categorie

\ & Apparence et themes

&
I—.-"‘l Connexions réseau et

! Internet
L

Ajouter ou supprimer des
programmes

Sons, ¥oid et périphétriques

& f:_g}‘ audio

Performances et

H maintenance

Dans la fenétre des
options régionales,
date, heure et
langue , double-
cliquer sur Options
régionales et
linguistiques

o

28

‘.'_,,.-—

&
L
v

)

N/

Imprimantes et autres
périphériques

Comptes d'utilisateurs

Options régionales, date,
heure et langue

Options d accessibilité

Centre de sécurité

Dptions régionales, date, heure et langue

Choisissez une tache...

Modifier la date et 'heure

E| Maodifier le format des nombres; des dates et de I'heure

E| Ajouter d autres langues

ou une icone du Panneau de

configuration

f.ﬁ Date et heure

(™ Dptions régionales et
<« linguistiques




Dans la fenétre
Options régionales
et linguistiques
cliquer sur I'onglet
Langues , puis sur le
bouton Détails...

Options régionales et linguistiques

| Options régionales | Langues

Options avancées

Services de texte et langues d'entrée

Pour afficher ou modifier les langues et lez méthodes que vous pouvesz utilizer
pour entrer du texte, cliquez sur Détailz.

Frize en charge de langues supplémentaires

La plupart des langues sont ingtallées par défaut. Pour installer d'autres
lahgues, sélectionnes lez option: comespondantes ci-dessous,

Inztaller le= fichiers pour les langues & soript complese et 2'écrivant de
draite & gauche [ce qui inclut le thalandais]

[ Installer les fichiers pour leg langues dEstréme-Orient

[ ] ][ Annuler ] Appliguer




Sélectionner le
clavier qui a été
installé.

Services de texte et langues d'entrée

Paramétres | Avanceg

Langue d'entrée par défaut

Sélectionnez une des langues d'entrée installées & utilizer lorsque volre
ordinateur dérmarre.

i Frangaiz [France] - Francais b
Anglais [Etatz-Uris] - Anglais [Etats-Unis]

Ia |IStE |_|tI|ISE2 Ies I:u:uutu:uns .-’-'-.p::uter et Supprlmer P ITIEIdIfIE[ cethe lizte,

f Reconnaizzance vocale L
Francaizs [France]

Clavier

= Frangais -

» Frangaiz - Soninké
&4 Reconnaizzance de ['éoriture manuscrite ;

= Drawing Pa v
< | ] Froprigtes..

Fréférences

[ Barre de langue. .. ] [Paramétres de tu:uuu:hes...]

[ ] ][ Annuler _H Appliquer




Cliquer sur OK pour
terminer.

Services de texte et langues d'entrée

Parammétres | Ay anics

Lanigue d'entrée par défaut

Sélectionnez une des langues d'entrée inztallées i utiliser loreque watre
ordinateur dérmarre.

Services inztallés

Choigizzez les services que vouz voulez pour chagque langue d'entrée de
la lizte. Utiizez les boutons Ajouter et Supprimer pour modifier cette liste.

f Reconnaiszance vocals ~l
Francaiz [France]
Clavier

»  Francais :
(W Francais - Soninké _
&% Reconnaizzance de ['écriture manuscrite -

» [rawing Pad P
(_ I >_' | Froprigtes..
Fréférences
[ Barre de langue... ] [F'aramétres de tu:uuu:hes...]

I:E k. H Annuler ][ Appliguer
e —

Conclusion :
Nous venons de créer un raccourci au caractére ). Désormais, grace aux touches du clavier [AltGr] + [n], on

peut insérer, saisir facilement et rapidement ce caractére dans n'importe quel éditeur de texte. Vous pouvez
bien s(r associer ce caractere a d’autres raccourcis de votre choix.






